Реферати українською » Экономико-математическое моделирование » Математичні методи дослідження в економіці


Реферат Математичні методи дослідження в економіці

Завдання 1.2

Цех хлібозаводу із виробництва борошна уклав угоду змини-пекарней щодо постачання щодня 300 кг житнього та пшеничного борошна, причому пшеничного - щонайменше 50%. Зерно, яке надходить до цеху, відбувається на ньому обмолот, помел й упаковки борошна.Трудозатрати (в людино-годинах) на зазначені операції представлені у таблиці:

Операція >Ржаная борошно Пшенична борошно Наявний ресурс
>Обмолот 0,1 0,1 30
>Помол 0,1 0,08 27
Упаковка 0,05 0,05 200

Собівартість одного кілограма житнього борошна становить 14 рублів, а пшеничного - 18 рублів.

Потрібна знайти оптимальний план виробництва, дозволяє цеху виконати умови контракти з найменшими витратами.

Рішення.

Нехай x1 - обсяги виробництва житнього борошна, x2 - обсяги виробництва пшеничного борошна. Тоді це може бути описано на вигляді наступній моделі лінійного програмування:

>Заполним дані серед Microsoft Excel


Додамо в таблицю ще одне рядок (наприклад, рядок 9 План), у якому вноситимуться одержувані працюючи над результати. Обсяг виробництва житнього борошна будемо припускати отримати у осередку В9, пшеничного борошна - в осередкуС9, а видатки собівартість - в осередкуD7.

Аби вирішити завдання необхідно також виокремити стовпець (у цьому прикладі - стовпець D), куди буде введено формули до розрахунку значень лівої частини обмежень. Формула вводиться й у осередок, у якій розраховані видатки собівартість підприємства (осередокD7). Потрібно звернути увагу, що у формулах використовуються не числа чи символьні позначення, а координати осередків таблиці, де зберігаються ці числа і які змінюються.


>D3=СУММПРОИЗВ(B3:C3;$B:$C)

>D4=СУММПРОИЗВ(B4:C4;$B:$C)

>D5=СУММПРОИЗВ(B5:C5;$B:$C)

>D7=СУММПРОИЗВ(B7:C7;$B:$C)

>D9=B9+C9

Для запуску процедури оптимізації в меню Сервіс необхідно вибрати пункт Пошук рішення. У центрі Встановити цільову осередок вводяться координати осередки (>D7), яку треба мінімізувати.

У центрі Змінюючи осередки вводяться координати осередків (розділені комами чи об'єднані у інтервал двокрапкою), які містять значення змінних - обсяги виробництва житнього та пшеничного борошна.Изменяемие осередки мали бути зацікавленими безпосередньо чи опосередковано пов'язані з цільової осередком. У центрі Обмеження необхідно провести все граничні умови завдання:


У цьому обмеження нанеотрицательность змінних можна запровадити шляхом установки прапорцяНеотрицательние значення вікні Параметри. Що стосується, якщо розв'язувана завдання є саме лінійного програмування, краще відзначити це у вікні Параметри відповідним прапорцем:

 

 

Запуск процесу оптимізації виробляється натисканням кнопки Виконати. Після закінчення рахунки з'являється діалогове вікно Результати пошуку рішення.Нажав у ньому відповідну кнопку, можна зберегти знайдене рішення чи відновити вихідні значення. Зміни у своїй торкнуться як цільової осередки, і впливають осередків. У цьому діалоговому вікні можна вказати необхідні типи звітів, які розміщені окремих аркушах книжки.

Звіт Результати відбиває вихідні і результуючі значення цільової і впливають осередків, і навіть інформацію про накладених обмеженнях.

 

Отже підприємству необхідно випустити 150 кг житнього страждання і 150 кг пшеничного борошна, тоді мінімальна собівартість випуску становитиме 4800 людино-годин, у своїй ресурси на обмолот і помел буде використано повністю, а ресурси на упаковку залишаться у надлишку у кількості 185 людино-годин.

 

Завдання 2.2

 

Керівництво птахофабрики має можливість закуповувати корми трьох видів. З положень цих кормів птахи повинні будуть отримувати живильні речовини (>П1,П2,П3 іП4), необхідну кількість яких і було вміст у кормах (в од.) наведені у таблиці:

Живильні

речовини

Корми Норми споживання
К1 >К2 К3
>П1 3 5 0 одно 16
>П2 2 2 4 щонайменше 24
>П3 8 1 2 щонайменше 25
>П4 4 3 5 щонайменше 33, але з понад 40 кримінальних

Ціни за 1 т кормів становлять відповідно 1000, 900 і 800 рублів.

Які корми й скільки слід закуповувати, аби птахофабрики виявилися мінімальними?

Рішення.

Рішення: позначимо за x1 кількість корми К1, за x2 - кількість кормиК2, за x3 - кількість корми К3. Тоді:

>Подготовим в Microsoft Excel таблицю на вирішення завдання:


 

Оскільки Microsoft Excel дозволяє шляхом установки відповідного прапорця автоматично визначатинеотрицательность змінних, додавання обмежень нанеотрицательность в модель під час вирішення завдання у Microsoft Excel перестав бути обов'язковим.

>Введем в таблицю формули до розрахунку лівих частин обмежень і цільової осередки:

>Е4=СУММПРОИЗВ(B4:D4;$B:$D)

>Е5=СУММПРОИЗВ(B5:D5;$B:$D)

>Е6=СУММПРОИЗВ(B6:D6;$B:$D)

>Е7=СУММПРОИЗВ(B7:D7;$B:$D)

>Е8=СУММПРОИЗВ(B8:D8;$B:$D)

Цільова осередокЕ10=СУММПРОИЗВ(B10:D10;$B:$D)

Обмеження запишуться так


Запустимо модуль Пошук рішення і зробимо розрахунки


У результаті розрахунків одержимо такі результати: оптимальний раціон мусить мати 3,125 од. корми К1, 4,6875 од. кормиК2 і 0,1875 корми К3. У цьому вартість раціону становитиме 7493,75 крб.

Завдання 3.1

Одне з цехів фабрики із пошиття виробів із шкірираскраивает вступники заготівлі щоб одержати 5 видів деталей однією з трьох можливих способів. З самої лише заготівлі отримують:

Спосіб розкроювання Деталі
A B З D E
I 10 5 3 7 2
II 6 8 4 5 2
III 4 7 5 3 4

Потрібна отримати щонайменше 48 деталей виду А менш 32 деталей виду У, щонайменше 45 деталей виду З, щонайменше 17 деталей виду D і проінвестували щонайменше 24 деталей виду Є.

Яке мінімум заготовок потрібно розкроїти?

Рішення.

Означимо за x1 кількість заготовок,разрезаемих за способом 1, за x2 - кількість заготовок,разрезаемих за способом 2 іт.д.Используя модель лінійного програмування з мінімізацією витрати матеріалу, одержимо:


>Подготовим таблицю в Microsoft Excel, що містить вихідні ці завдання, введемо формули до розрахунку цільової функції та скільки лівої частини обмежень, заповнимо форму модуля Пошук рішення:


Рішення


Отже, необхідно розкроїти 1 заготівлю способом I, 1 заготівлю способом II, 8 заготовок способом III.

 

Завдання 4.2

Громадянин Про. Бендер хоче придбати якийсь меблевий гарнітур, вартість якої 100 тис. рублів. Адміністрація аукціону згодна на виплату на виплату, з вимогою, що 20 тис. крб. Про. Бендер виплатить через 2 місяці, а решту суми - через 4 місяці.

Проте Про. Бендер, справедливо вважаючи, що швидко знайти необхідну суму йому вдасться, хоче кошти шляхом вкладення великих грошей однієї зі типів вкладу: А (терміном озер місяцем під 1,5%), У (терміном на 2 місяці під 3,5%) або з (терміном на виборах 4 місяці під 8%).

Яку суму і яким типу вкладу потрібно вкласти Про. Бендеру, аби за 4 місяці купити гарнітур?

Тип вкладу Термін вкладу (міс.) Відсоток за внеском
A 1 1,5
B 2 3,5
З 4 8,0

Необхідно мінімізувати розмір цільового фонду.

Рішення:

>Составим таблицю, яка відображатиме можливості вкладення і повернення грошей по місяців:

Вклади 1 2 3 4 5
>A1 1®® 1,015
>A2 1®® 1,015
>A3 1,015
>A4 1®® 1,015
>B1 1®® ®®® 1,035
>B3 1®® ®®® 1,035
>C1 1®® ®®® ®®® ®®® 1,08

де:Ai - розмір вкладу типу A в місяці і;Bi - розмір вкладу типу B в місяці і;Ci - розмір вкладу типу З в місяці і;

Завдання то, можливо описана наступній моделлю:


Функція >minimize повертає вектор значень змінних, є аргументами цільової функції, у яких його значення буде мінімальним. У першій колонці – порядковий номер перемінної, починаючи з нульового, по черговості згадки. У другій – відповідні значення змінних.

За необхідності, присвоївши змінним отримані значення, можна розрахувати і значення цільової функції.

Завдання 5.2

Чотири фермерських господарства, перебувають у Рязанської, Володимирській, Тверській і Смоленської областях, направляють вирощувані овочі й фрукти на переробку і консервацію однією із трьох заводів, найчастіше розташованих у Москві, Тулі і Ярославлі.

Витрати на перевезення 1 т продукції представлені у таблиці (в рублях):

Москва Тула Ярославль
>Рязанское 500 700 800
Володимирське 400 800 300
Тверське 400 700 400
Смоленське 600 600 700

У сезонРязанское господарство виробляє 40 т продукції тиждень, Володимирське - 50 т, Тверське - 60 т, Смоленське - 70 т, тоді як на заводі Москві може переробити на тиждень 100 т продукції, у Тулі - 50 т, в Ярославлі - 40 т.

Складіть план перевезень продукції з фермерських господарств на заводи з мінімальними транспортними видатками, враховуючи, що у зв'язки України із ремонтом трасиМосква-Рязань на тиждень за нею можна перевезти трохи більше 20 т продукції.

Рішення:

У цьому завданню кількість вирощуваних продуктів, на 30 т більше, ніж спроможні переробити заводи.Сведем завдання до замкненому виду, додавши фіктивного п'ятого постачальника.

Модель аналізованої завдання така:

Зауважимо, що у цільову функцію не запроваджені штрафи занереализацию продукції зв'язку з їхнім відсутністю умови завдання.

А, щоб задовольнити вимозі замість Московського заводу введемо двох інших.

Одне з них, під назвою Московського заводу матиме потреби, тобто можливості у переробці у кількості 20 т і з тими самими вартостями перевезень, а другий із можливістю 100 – 20 = 80 і з тими самими вартостями перевезень, крім з15, яку приймемо рівної як завгодно великому числу, наприклад, 1000000000.

Після перебування оптимального плану обсяги перевезень у Москві необхідно додати до обсягам перевезеньПотребителя 2


Через війну вихідна завдання набуде вигляду



Москва Тула Ярославль Споживач 1 Споживач 2 Ресурси
>Рязанское 500 700 800 0 10000000000 40
Володимирське 400 800 300 0 400 50
Тверське 400 700 400 0 400 60
Смоленське 600 600 700 0 600 70
Потреби 20 50 40 30 80 220

Вирішимо завдання з допомогою модуля Пошук рішення:

Цільова осередокD19 =>СУММПРОИЗВ(B2:F5;B12:F15)



Отримуємо рішення

З урахуванням обмежень на трасуМосква-Рязань остаточно отримуємо план перевезень

Москва Тула Ярославль
>Рязанское 20 0 0
Володимирське 10 0 40
Тверське 60 0 0
Смоленське 10 50 0

І остаточну вартість

 20*500+10*400+60*400+10*600+50*600+40*300 = 86000 у.о.


Завдання 6.2

Фірма отримала замовлення терміновий переклад чотирьох книжок із італійської. Фірма може розташовувати послугами 5 перекладачів, здатних виконати роботу цього рівня. Час в днях, протягом якого кожен перекладач чи впорається з роботою, наведено в таблиці:

Книжка 1 Книжка 2 Книжка 3 Книжка 4
Іванов 10 25 14 25
Петров 8 12 16 28
Сидоров 12 18 17 33
Андрєєв 14 23 15 30
Васильєв 11 20 18 28

Фірма використовує погодинну оплату праці. Перекладачі мають різну кваліфікацію, тому протягом дня роботи фірма платить Іванову 700 карбованців на день, Петрову - 800 карбованців на день,Сидорову - 600, Андрєєвим - 500, Васильєву - 550. Оскільки за оцінкою фірми якість перекладів у результаті приблизно однаковим, керівництво фірми просить Вас скласти такий розподіл робіт, що дозволить мінімізувати видатки переклади.

Рішення.

>Составим модель лінійного програмування, яка відображатиме умова:


Вирішимо завдання з допомогою Microsoft Excel:

За позитивного рішення завдань про призначення особливий інтерес викликає спосіб введення обмежень під час заповнення форми модуля Пошук рішення і формули цільової функції:



Проведені розрахунки доводять, що мінімальне загальні видатки переклад склали 48800 рублів. Призначення перекладача для перекладу книжки визначається наявністю на перетині рядки - і шпальти значення 1.

Книгу 1 — Петров

Книгу 2 — Іванов

Книгу 3 — Васильєв

Книгу 4 — Андрєєв


Схожі реферати:

Навігація